Filtering Route EIGRP

Posted: June 10, 2009 in Cisco

Kemarin dapat pengalaman baru lagi mengenai EIGRP,, kasusnya yaitu filtering EIGRP. Mengapa harus di filtering, karena router yang dijadikan load balancing ini tidak boleh advertise network yang ada dibelakangnya. Sebut saja router yang dimaksud Router A. Router A ini mempunyaI 2 link internet ke ISP. Jadi rule nya router ini menjadi router load balancing, jika salah link ISP ada yang putus atau down maka secara otomatis koneksi internet akan pindah ke link backup. Router-rotuer yang digunakan diperangkat dalam kasus ini adalah cisco. Protokol routing yang digunakan tentu saja sesuai judul diatas yaitu EIGRP.Gimana lanjut ?? Tapi Bikin Kopi dulu cuy,.

Network Diagram sebagai berikut
eigrp

R1 (Router ISP) —- > Main Link
int f0 // merupakan int b2b ke Router A

R2 (Router ISP) —- > Main Link
int f0 // merupakan int b2b ke Router A

Router A
int f0 // merupakan int b2b ke R1
int f1 // merupakan int b2b ke R2

Note :
– Dalam kasus ini peran delay sangat penting untuk menentukan link akan dilewatkan ke jalur mana. Semakin delay kecil maka link tersebut otomatis menjadi main link. Bingung ??
– IP B2B haruslah primary, jika secondary sepertinya tidak bisa.
– misalkan network ISP 202.202.178.x (Contoh cuy)

OK lanjut ke konfigurasi

R1 (Router ISP)
description ip b2b to Router A
interface FastEthernet0
ip address 202.202.178.1 255.255.255.252
delay 1000

router eigrp 212

R2 (Router ISP)
interface FastEthernet0
description ip b2b to Router A
ip address 202.202.178.5 255.255.255.252
delay 2000

R3 (Router A)
interface Loopback0
description Loopback Interface
ip address 202.202.92.1 255.255.255.255

interface FastEthernet0
description gateway LAN (Public)
ip address 202.202.178.9 255.255.255.248

router eigrp 212
network 202.202.178.0 0.0.0.255
distribute-list prefix Outgoing_Filter out
distribute-list prefix Incoming_Filter in
no auto-summary
no eigrp log-neighbor-changes
no eigrp log-neighbor-warnings

ip prefix-list Incoming_Filter description EIGRP Incoming Filter List
ip prefix-list Incoming_Filter seq 5 permit 0.0.0.0/0
ip prefix-list Incoming_Filter seq 50 deny 0.0.0.0/0 le 32
!
ip prefix-list Outgoing_Filter description EIGRP Outgoing Filter List
ip prefix-list Outgoing_Filter seq 5 permit 202.202.92.1/32
ip prefix-list Outgoing_Filter seq 10 permit 202.202.178.8/29

Kita bahas satu-satu nyok rule diatas ..tapi kl ada yang salah tolong dibenerin okay… namanya juga newbie..he.h.e.eh

router eigrp 212
network 202.202.178.0 0.0.0.255
distribute-list prefix Outgoing_Filter out
distribute-list prefix Incoming_Filter in

rule diatas dimaksudkan mendefinisikan bahwa ip prefix yang sudah dikelompokkan kedalama filter outgoing dan filter in.
Sudnya EIGRP akan mendistribute ip prefix yang sudah didaftarkan dibawahnya. Rule diatas ada hubungan dengan rule dibawah ini.

ip prefix-list Incoming_Filter description EIGRP Incoming Filter List
ip prefix-list Incoming_Filter seq 5 permit 0.0.0.0/0
ip prefix-list Incoming_Filter seq 50 deny 0.0.0.0/0 le 32
!
ip prefix-list Outgoing_Filter description EIGRP Outgoing Filter List
ip prefix-list Outgoing_Filter seq 5 permit 202.202.92.1/32
ip prefix-list Outgoing_Filter seq 10 permit 202.202.178.8/29

Kita bahas baris pertama dulu,, ip prefix-list Incoming_Filter seq 5 permit 0.0.0.0/0 artinya ip default zero akan diizinkan masuk, sesuai dengan directed connected router tentunya. Sedangkan ip prefix-list Incoming_Filter seq 50 deny 0.0.0.0/0 le 32 yaitu selain ip default zero tentunya akan di denied (tidak diizinkan masuk).

Kemudian baris kedua ip prefix-list Outgoing_Filter seq 5 permit 202.202.92.1/32
ip prefix-list Outgoing_Filter seq 10 permit 202.202.178.8/29
artinya bahwa network yang akan diadvertise keluar router terdiri dari ip loopback dan ip network yang ada dibelakang router A.

Untuk pengecekannya bisa dilakukan dengan perintah
sh ip route // melihat ip default zero
sh ip eirgrp neighbor // untuk melihat jaringan router yang terhubung , normalnya akan terdetek 2 router interface

Untuk lebih jelasnya klik disini

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s