Static Routing dengan default route

Posted: June 18, 2009 in Cisco

Berikut simple diagram static route dg ip route zero-zero (0.0.0.0/0). Simulator yang gue pake yaitu Routersim 6.0, ga terlalu powerfull c ketimbang gns3. Tapi PC gue belum diinstall GNS3,, akang Fery keburu resign sich,, jadinya ga jadi install gns3. Ok tidak usah tunggu lama lagi,, lanjutkan

Diagram Network yang gue coba seperti dibawah ini :
network simple static route
Router A
int f0/0 : 10.0.0.1/30 // ip b2b dg Router B
int f0/1 : 192.168.1.1/24

Host A
ip address : 192.168.1.10/24
gw : 192.168.1.1 // gw ada di Router A

Host B
ip address 192.168.1.20/24
gw : 192.168.1.1 // gw ada di Router A

Router B
int f0/0 : 10.0.0.2/30 // ip b2b dg Router B
int f0/1 : 172.16.10.1/24

Host C
ip address : 172.16.10.10/24
gw : 172.16.10.1 // gw ada di Router B

Host D
ip address : 172.16.10.20/2
gw : 172.16.10.1 // gw ada di Router B

ok coba kita test ping,, dari Host C ke Host A,, ping 192.168.1.10, ternyata hasilnya RTO.
Ping Host A (RTO)
Kenapa ya? ?wekss,, ya jelas saja RTO karena host C dan host A beda network. Walaupun sudah ada router,, tapi fungsi routingnya belum diaktifikan/konfigur. oK coba kita masuk ke router A, dengan menambahkan static routingnya..Sintaksnya sebagai berikut :

ip route network [mask] {address | interface}[distance] [permanent]

Sebelumnya diset gw masing-masing host, seperti hasil show run berikut dibawah ini :

router_A#sh run

interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.252
no ip directed-broadcast
!
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast
!
interface FastEthernet0/1.1
!
interface Serial0/0/0
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0/0/1
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0/1/0
ip address 10.0.1.1 255.255.255.252

ip route 0.0.0.0 0.0.0.0 10.0.0.2

Parameter Perintah “ip route”
ip route : Menyatakan rute statik
0.0.0.0 : Rute ke “nonexistent subnet”(mencakup semua IP)
0.0.0.0 : Special mask mengindikasikan “default route”
172.16.2.2: Alamat IP Router A.

sekarang router B, sama aja konfigurasinya dg Router A, set gateway ip untuk masing-masing host..
konfigurasi seperti show run dibawah ini

interface FastEthernet0/0
ip address 10.0.0.2 255.255.255.252
no ip directed-broadcast
!
interface FastEthernet0/1
ip address 172.16.10.1 255.255.255.0
no ip directed-broadcast
!
ip route 0.0.0.0 0.0.0.0 10.0.0.1

10.0.0.1 dan 10.0.0.2 merupakan next hop dari network sebelumnya

ok sekarang ping kembali dari Host C ke Host A,, coba lihat hasilnya…

Ping Host A

Hore ,, ternyata reply….wkwkwkw

Kesimpulan

1. Rute Statik menjadi sangat penting jika software IOC Cisco tidak bisa membentuk sebuah rute ke tujuan tertentu. Rute Statik juga sangat berguna untuk membuat “gateway” untuk semua paket yang tidak bisa di”routing”.(default route).

2. Rute statik dapat digunakan untuk koneksi ke suatu network yang tidak terhubung langsung dengan router anda. Untuk koneksi “end-to-end”, rute statik harus dikonfigurasi di dua arah.

Coba Sekarang static routingnya pake 4 router gmn ?.. Berani tak.. ?? lanjutkan

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s