RIP (Routing Information Protocol)

Posted: July 24, 2009 in Cisco

Setelah kemarin belajar statis route, sekarang coba2 yuk routing dinamis. Salah satu routing dinamis yang dipakai untuk jaringan skala kecil yaitu RIP. Protokol routing ini sdh banyak diadopsi oleh perangkat router lainnya sepetri cisco , mikrotik, juniper, dll. Tapi kali ini gue coba ilustrasiin RIP di Cisco. Lanjut ? Tapi gue nganTuk cuy,, waktunya ngupi dulu.. Bentar ya..

Ok,,lanjut.. Berikut diagram network RIP yang kita coba..Check this out…
Network Diagram RIP (Simple aja cuy..)

Kita cek router-1 dan router-2 dulu..Konfigurasi sesuai dengan gambar diatas.
host-wiwid : 10.10.1.2/30 ==== > ip gateway : 10.10.1.1
host-dodi : 10.10.2.2/30 ==== > ip gateway : 10.10.2.1

router-1
interface FastEthernet0/0
description gateway host-wiwid
ip address 10.10.1.1 255.255.255.252
!
interface FastEthernet1/0
description b2b router-2
ip address 172.172.1.1 255.255.255.252

router-2

interface FastEthernet0/0
description gateway host-dodi
ip address 10.10.2.1 255.255.255.252
!
interface FastEthernet1/0
description b2b router-1
ip address 172.172.1.2 255.255.255.252

Ingat y,simplenya dari kedua router ini,, kl proses routing berjalan baik, yang lainnya akan sama.Coba kita cek paket icmp nya..Ping dari host-wiwid ke host-dodi

C:>ping 10.10.2.1
Pinging 10.10.2.1 with 32 bytes of data:

Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 10.10.2.1:
Packets: Sent = 5, Received = 0, Lost = 5 (100% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms

Duhh ko RTO (request Time out). Kl seperti ini biasanya ditable routing kedua router tidak sama. Sehingga karena network wiwid dan dodi berbeda, maka yang terjadi RTO. Coba kita lihat routing tablenya, di router-1

router-1#sh ip route

10.0.0.0/30 is subnetted, 1 subnets
C 10.10.1.0 is directly connected, FastEthernet0/0
172.172.0.0/30 is subnetted, 1 subnets
C 172.172.1.0 is directly connected, FastEthernet1/0

Network dodi yaitu 10.10.2.0 tidak ada, makanya koneksi RTO. Sekarang kita masukkan routing table nya di router-1. Karena judul diatas adalah soal RIP, maka parameter routing tablenya juga rip.

ok Caranya kurang lebih seperti ini.. login ke router-1

router-1

router-1(config)#
router-1(config)#router ri
router-1(config-router)#network 10.10.1.0
router-1(config-router)#network 172.172.1.0
router-1(config-router)#^Z
%SYS-5-CONFIG_I: Configured from console by console

coba lihat konfigurasinya, dengan perintah show run

interface FastEthernet0/0
description gateway host-wiwid
ip address 10.10.1.1 255.255.255.252

interface FastEthernet1/0
description b2b router-2
ip address 172.172.1.1 255.255.255.252

router rip
network 10.0.0.0
network 172.172.0.0

Perhatikan konfigurasi diatas setelah di show ternyata network rip yang muncul 10.0.0.0 dan 172.172.0.0. Ko bisa?? karena karakteristik RIP adalah classfull, jadi apapun network yang diberikan maka yang diambil adalah network utama kelasnya. Tadi network yang dimasukkan adalah 172.172.1.0 dan 10.10.1.0. Penjelasannya
172.172.1.0 adalah kelas B, sehingga pada router akan digenerate menjadi 172.172.0.0
10.10.1.0 adalah kelas A, sehingga pada router menjadi 10.0.0.0…ok lanjut..

Pada router-2, network rip yang dimasukkan sama seperti router-1.
Konfigurasi router-2
interface FastEthernet0/0
description gateway host-dodi
ip address 10.10.2.1 255.255.255.252

interface FastEthernet1/0
description b2b router-1
ip address 172.172.1.2 255.255.255.252
!
router rip
network 10.0.0.0
network 172.172.0.0

Kita cek paket icmp nya melalui ping, dari host-wiwid ke host-dodi

C:#ping 10.10.2.2
Pinging 10.10.2.2 with 32 bytes of data:

Reply from 10.10.2.2: bytes=32 time=60ms TTL=241
Reply from 10.10.2.2: bytes=32 time=60ms TTL=241
Reply from 10.10.2.2: bytes=32 time=60ms TTL=241
Reply from 10.10.2.2: bytes=32 time=60ms TTL=241
Reply from 10.10.2.2: bytes=32 time=60ms TTL=241

Ping statistics for 10.10.2.2: Packets: Sent = 5, Received = 5, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 50ms, Maximum = 60ms, Average = 55ms

Ternyata berhasil,, untuk bisa ping ke router lainnya (router-3 dan router-4), semua network yang ada pada network diagram diatas harus didaftarkan ke routing table masing-masing router..

Hore…Hore..Hore…

Karakteristik RIP (ini sich sepengetahuan gue aja)..he.he..he
1. Hop yang bisa disupport cuma sampe 15 hop aja, jadi jaringan yang anda buat kemungkinan tidak begitu besar. Karena hanya 15 hops saja yang bisa dibuat.
2. Setiap Router yang saling terhubung saling mengupdate informasi routing tablenya setiap 30 detik.
3. RIP ada 2 versi, RIP-1 Classfull dan RIP-2 Classless (bener tak).. kalo yang diatas RIP-1
4. Untuk routing convergence (Berkumpul)nya paling lama dibanding EIGRP, OSPF, dan IS-IS

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s