Fail Over Mikrotik With Redistribute OSPF To EIRGP

Posted: November 13, 2009 in Cisco, EIGRP, Networking

fail over mikrotik dg 2 router eigrp
Alhamdulillah, kemarin dari MUM kantor beli RB 750. Dari pada ga ada yang pakai, gue test aja ngoprek2 kata wong jowo. Melanjutkan fail over mikrotik dengan EIGRP yang pernah gagal,hikzz…Akhirnya kemarin 2 harian (sampe nginep dikantor) coba ngoprek lagi..Bis teriinspirasi sama presentasi di MUM tentang routing filtering OSPF, ternyata route filtering ospf di versi 3.xx sampai 4.x sudah ada..Wah berarti bisa nich maen filtering di OSPF Mikrotik. Gimana Penasaran ?? .he.he..he

Langsung saja ya (lihat gambar),, Skenarionya seperti dibawah ini :
1. Dari Router-A & B ada ip B2B ke router mikrotik
2. Router-A & B ngomong ke mikrotik, pakai OSPF.
3. Router-A & B ada koneksi EIGRP ke INTERNET
4. Router-A & B akan redistribute OSPF TO EIGRP

Untuk menghindari akan masuknya network-network yang tidak diinginkan, maka dibuatkan filitering route ospf sbb :
1. OSPF-in : Hanya informasi default route 0.0.0.0/0 yang diterima, lainnya di-deny atau dischard
2. OSPF-out : Hanya informasi network B2B dan network tertentu saja yg di-advertise keluar, selain itu
deny atau dischard.
3. OSPF-out : Hanya informasi network loopback yang di-advertise keluar, selain itu deny any atau dischard
ingat ya rulenya jangan terbalik urutan antara no.2 dan no.3

OK berikut config Router-A

interface FastEthernet3/0.301
description Testing OSPF Mikrotik
encapsulation dot1Q 301
ip address 172.172.10.1 255.255.255.252
end

router eigrp 88
redistribute ospf 77 metric 1500 10 255 1 1500

router ospf 77
router-id 172.172.172.1
log-adjacency-changes
passive-interface default
no passive-interface FastEthernet3/0.301
network 172.172.10.0 0.0.0.3 area 66
default-information originate
distribute-list prefix OSPF_Filter_Out out
distribute-list prefix OSPF_Filter_In in

ip prefix-list OSPF_Filter_In seq 5 deny 0.0.0.0/0
ip prefix-list OSPF_Filter_In seq 10 permit 0.0.0.0/0 le 32
!
ip prefix-list OSPF_Filter_Out seq 5 permit 0.0.0.0/0
ip prefix-list OSPF_Filter_Out seq 10 deny 0.0.0.0/0 le 32

Config Router-B

interface FastEthernet0/1.302
description Testing OSPF Mikrotik
encapsulation dot1Q 302
ip address 172.172.20.1 255.255.255.252
no snmp trap link-status
!
router eigrp 88
redistribute ospf 77 metric 1500 10 255 1 1500

router ospf 77
router-id 202.47.79.16
log-adjacency-changes
passive-interface default
no passive-interface FastEthernet0/1.302
network 172.172.20.0 0.0.0.3 area 66
default-information originate
distribute-list prefix OSPF_Filter_Out out
distribute-list prefix OSPF_Filter_In in

ip prefix-list No_Zero_Prefix seq 5 deny 0.0.0.0/0
ip prefix-list No_Zero_Prefix seq 10 permit 0.0.0.0/0 le 32
!
ip prefix-list OSPF_Filter_In seq 5 deny 0.0.0.0/0
ip prefix-list OSPF_Filter_In seq 10 permit 0.0.0.0/0 le 32

OK sekarang lanjut ke config mikrotik, sesuai gambar untuk backup linknya adalah link Router-A.
Bagaimana menentukan main link dan backup link, yaitu dengan cara menentukan nilai COST & PRIORITY pada interface OSPF mikrotik

Ok Lanjut,, Berikut urutannya
1. Buat Interface loopback

[wiwid@Mikrotik] > /interface bridge add name=lobridge

2. Create ip address interface loopback
[wiwid@Mikrotik] > /ip address add address=172.172.172.3/32 interface=lobridge
3. Create ip address interface B2B (ether1 & ether2)

[wiwid@Mikrotik] > /ip address add address=172.172.10.2/30 interface=ether1
[wiwid@Mikrotik] > /ip address add address=172.172.20.2/30 interface=ether2

4. Tentukan interface OSPF

[wiwid@Mikrotik] /routing ospf interface add cost=20 priority=1 instance-id=0 interface=ether1 network-type=broadcast
[wiwid@Mikrotik] /routing ospf instance> set 0 router-id=202.47.77.198 distribute-default=never redistribute-connected=as-type-1

5. Create Area-ID,
Area-ID ini harus sama dengan process-id dan area cisco router. Pada simulasi ini area-id adalah 66 dan kita beri nama SGH

[wiwid@Mikrotik] /routing ospf area add area-id=0.0.0.66 instance=default name=ospf

6.Create Network OSPF

Untuk network ospf cukup networkB2B saja yang dicreate.
[wiwid@Mikrotik] /routing ospf network add area=ospf network=172.172.10.0/30
[wiwid@Mikrotik] /routing ospf network add area=ospf network=172.172.20.0/30

7. Konfigurasi filtering route ospf mikrotik, seperti dibawah ini :

[wiwid@Mikrotik] /routing filter add action=discard chain=ospf-in prefix=!0.0.0.0/0
[wiwid@Mikrotik] /routing filter add action=accept chain=ospf-out prefix=172.172.10.2/30
[wiwid@Mikrotik] /routing filter add action=accept chain=ospf-out prefix=172.172.20.2/30
[wiwid@Mikrotik] /routing filter add action=discard chain=ospf-out prefix=!172.172.172.3/32

Untuk mengecek OSPF nya, bisa dilihat di :
routing ospf neighbor print
ip route print // untuk melihat default route yang didapat dari router cisco.

Thankss semoga bermanfaat,, i like mikrotik…..

Advertisements
Comments
  1. Dodie says:

    Mantap Gan…Lanjutkan…!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s