Script Tool Netwatch Sending Email …

Posted: February 2, 2010 in MikroTik

Alooww Bro,, ini ada sedikit script mikrotik tapi mungkin cara kuno atau jadul kalee ya,, Mungkin ada yang punya script yang lebih canggih lagi,, dan keren tentunya,,tp gpp,, Namanya juga berbagi,,so semoga bermanfaat. Ini script tool netwatch,, dimana jika ada host yang tidak terdetek maka akan email ke email tujuan sebaliknya jika host tsb “up”, maka akan email jg ke no email yang dituju. Ok langsung aja ya….
Berikut stepnya..

1. Setting email dan server email nya :

/tool e-mail
set from=wiwid@mikrotik.com password=”” server=202.202.202.1:25 \
username=””

Note :
item “from” boleh diisi apa saja, sesuai keinginan anda
“server” : isikan ip smtp server anda, port 25 merupakan port default smtp
Pastikan ip smtp anda “allow access” maksudnya bisa di ping dari server mikrotik anda. Jika di-ping statusnya RTO kemungkinan akan gagal proses pengiriman ke email tujuan. Lanjut Bro ..

2. Kemudian, configure “tool netwatch” seperti dibawah ini :

* Script-up * script ini akan menjalankan protokol ICMP, jadi ketika host tujuan berhasil di ping atau statusnya UP, maka script akan running dengan mengirimkan email ke email tujuan.
* Script-Down * script ini akan menjalankan protokol ICMP, jadi ketika host tujuan tidak berhasil di ping atau statusnya DOWN, maka script akan running dengan mengirimkan email ke email tujuan.

Berikut command nya :

/tool netwatch
add comment=”Netwath Sending Email” disabled=no down-script=”tool e-mail send from=wiwid@mikrotik.com server=202.202.202.1 to=symbal.pecah@gmail.com s\
ubject=\”Perangkat Down Bro\” body=\”Hayo,, Perangkat Bisa DOWN gietu sich\”” host=172.16.101.100 interval=1m timeout=1s up-script=”tool e-mail send fro\
m=wiwid@mikrotik.com server=202.202.202.1 to=symbal.pecah@gmail.com subject=\”Perangkat UP\” body=\”Hore, Perangkat UP lagi,, bisa tidur nich\””

Penjelasan sedikit :
host=172.16.101.100 , host bisa anda bisa disesuaikan ya..Jadi ip ini akan di ping oleh server mikrotik, jika “REPLY” script-up akan running, jika ping “RTO” maka script-down yang akan running

Gimana,, ?? Just it simple kan,, mungkin suhu2 mikrotik,, punya cara lain…yang lebih menarik lagi..
OK, selanjutnya tahap pengetesan,, kita cek email. Kebetulan email gue diarahin ke gmail

Berikut screen shot Script-UP

Capture By Wiwid

Kalo Script-Down running,,

Capture By Wiwid

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s