combination of static routing, NAT, and PAT

Posted: February 5, 2010 in Cisco, Networking

Sore Bro,, hayah,,, lihat Judulnya ribet banget ya… Wk88,, namanya juga newbie,,,Ya nichh lagi mantebin static routing,, kebetulan disini gue kombinasiin dengan NAT dan PAT..Jadi dari 6 router percobaan, ada 1 router yang sebagai Router WAN. yang lain nya di NAT ,dan untuk akses telnet nya gue PAT.

Berikut gambarnya…

Capture By Wiwid

Mau Lanjut ??

Penjelasan Dikit …

1. R0, sebagai Router WAN,
2. R1 s/d R5, sebagai Router CPE..
3. R0, F0/0 ===>10.8.8.238/24 (WAN) === > IP NAT OUTSIDE
R0, F1/0 s/d F2/0 ===> IP NAT INSIDE

Berikut Config R0

interface FastEthernet0/0
ip address 10.8.8.238 255.255.255.0
ip nat outside
duplex auto
speed auto
!
interface FastEthernet1/0
description to R1
ip address 172.16.10.1 255.255.255.252
ip nat inside
duplex auto
speed auto
!
interface FastEthernet2/0
description to R2
ip address 172.16.20.1 255.255.255.252
ip nat inside
duplex auto
speed auto
!
ip nat inside source list 1 interface FastEthernet0/0 overload
ip nat inside source static tcp 192.168.10.2 23 interface FastEthernet0/0 238
ip nat inside source static tcp 172.20.20.2 23 interface FastEthernet0/0 233
ip nat inside source static tcp 172.16.10.2 23 interface FastEthernet0/0 231
ip nat inside source static tcp 172.16.20.2 23 interface FastEthernet0/0 235
ip nat inside source static tcp 172.20.10.2 23 interface FastEthernet0/0 234
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 10.8.8.1
ip route 172.20.10.0 255.255.255.252 172.16.10.2
ip route 172.20.20.0 255.255.255.252 172.16.10.2
ip route 192.168.10.0 255.255.255.252 172.16.20.2
!
access-list 1 permit 172.16.10.0 0.0.0.3
access-list 1 permit 172.16.20.0 0.0.0.3
access-list 1 permit 172.20.10.0 0.0.0.255
access-list 1 permit 172.20.20.0 0.0.0.3
access-list 1 permit 192.168.10.0 0.0.0.3

Dari config R0 diatas, ini config PAT nya..

ip nat inside source static tcp 192.168.10.2 23 interface FastEthernet0/0 238
ip nat inside source static tcp 172.20.20.2 23 interface FastEthernet0/0 233
ip nat inside source static tcp 172.16.10.2 23 interface FastEthernet0/0 231
ip nat inside source static tcp 172.16.20.2 23 interface FastEthernet0/0 235
ip nat inside source static tcp 172.20.10.2 23 interface FastEthernet0/0 234

Config R1

interface FastEthernet0/0
description to R2
ip address 172.20.20.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 172.16.10.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/0
description to Router-4
ip address 172.20.10.1 255.255.255.252
duplex auto
speed auto
!
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.10.1
ip route 172.20.30.0 255.255.255.252 172.20.20.2

Config R2

interface FastEthernet0/0
description To R5
ip address 192.168.10.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
description to R3
ip address 172.20.30.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/0
description to R0
ip address 172.16.20.2 255.255.255.252
duplex auto
speed auto
!
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 172.20.30.1 10 name Route-Via-R3
ip route 0.0.0.0 0.0.0.0 172.16.20.1 20 name Route-Via-R0
ip route 172.20.10.0 255.255.255.252 172.20.30.1
ip route 172.20.20.0 255.255.255.252 172.20.30.1

Config R3

interface FastEthernet0/0
description To R1
ip address 172.20.20.2 255.255.255.252

interface FastEthernet1/0
description to R2
ip address 172.20.30.1 255.255.255.252
duplex auto
speed auto

ip route 0.0.0.0 0.0.0.0 172.20.20.1

Config R4

interface FastEthernet0/0
description to R1
ip address 172.20.10.2 255.255.255.252
duplex auto
speed auto
!
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 172.20.10.1
ip route 172.20.30.0 255.255.255.252 172.20.10.1

Config R5

interface FastEthernet0/0
description To R2
ip address 192.168.10.2 255.255.255.252
duplex auto
speed auto
!
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.10.1
!

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s