Simple IPIP Tunnel Cisco

Posted: February 8, 2010 in Cisco, Networking, Tunneling

Dear Bro n Sista,,

Pasti dah denger banyak tentang Tunneling. Ya,,Tunneling diartikan sebagi suatu cara untuk engenkapsulasi (membungkus) paket IP didalam paket IP yang lain. Dimana titik dibelakang IP Tunnel akan memberikan paket IP melalui Tunnel yang dibuat dan mengirimkannya ke sebuah titik dibelakang tunnel yang lain.

Atau bisa juga,,suatu cara membuat jalur private (lokal) dengan menggunakan infrastruktur pihak ketiga / jalur public (Internet). Nah,, Banyak protocol tunneling, ada EOIP, PPTP, dll. Dan kalii ini gue coba publish tunneling dg IPIP. Simple sich,, namanya jg belajar….he.h.e.

Capture By Wiwid

lanjut ?

Scenarionya kurang lebih seperti ini :
1. Router yang ditengah,, adalah router gateway (INTERNET). Alokasi IP 10.8.8.X/24
Router ini biasa d,, gue naekin IP NAT OUTSIDE dan IP NAT INSIDE,, biar R6 dan R2 bisa internetan..
2. R2, IP 172.16.10.X merupakah IP B2B To Internet..dan ip tunneling nya 192.168.1.1/24
3. R2, IP 172.16.20.X merupakah IP B2B To Internet..dan ip tunneling nya 192.168.1.2/24

OK Confignya kurang lebih seperti ini.

Config R0

interface FastEthernet0/0
ip address 10.8.8.238 255.255.255.0
ip nat outside
!
interface FastEthernet1/0
ip address 172.16.10.1 255.255.255.0
ip nat inside
!
interface FastEthernet2/0
description To R2
ip address 172.16.20.1 255.255.255.252
ip nat inside

Config Router-6

interface Tunnel0
ip address 192.168.1.2 255.255.255.0
tunnel source 172.16.20.2
tunnel destination 172.16.10.2
tunnel mode ipip
tunnel key 235
!
interface FastEthernet0/0
description to Router-0
ip address 172.16.20.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.60.1 255.255.255.252
duplex auto
speed auto

config R2

policy-map TUN
class class-default
shape average 128000

interface Loopback0
ip address 192.168.168.1 255.255.255.248
!
interface Tunnel0
ip address 192.168.1.1 255.255.255.252
service-policy output TUN
tunnel source 172.16.10.2
tunnel destination 172.16.20.2
tunnel mode ipip
tunnel key 235
!
interface FastEthernet1/0
description to R0
ip address 172.16.10.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/0
description to Router-4
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 172.16.10.1
ip route 192.168.168.0 255.255.255.248 Tunnel0

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s