Cisco Single BGP with Default Route

Posted: February 11, 2010 in BGP, Cisco, Networking

Dear Bro n Sista,

Jam sdh menunjukkan 17.30,, waktunya belajar lagi.. Kali ini belajar BGP kali ya,, bisnya maen di jaringan kantor para senior belum kasih kepercayann, alhasil ya simulasi aja..Toch,, yg penting bisa praktek,,.
ok, sesuai judulnya mw simulasi “Cisco Single BGP with Default Route”. Dimana ada satu customer yang terhubung dg salah satu ISP, kayanya gede nich customer bis punya ASN sich..he..he..
Scenario .
1. Routing BGP Internal sbg main routing, dan static routes sbg backup routing
2. AD static route, gue kasih 23,, agar dibawah AD BGP Internal yaitu 20. Ga tw kenapa,, kl AD static route dikasi 21 s/d 22 ko ga jalan ya BGP nya..Ada yang punya jawabannya ???

Capture By Wiwid

R0 (Router WAN/ISPs)

interface FastEthernet0/0
ip address 10.8.8.238 255.255.255.0
!
interface FastEthernet1/0
description to Customer
ip address 172.16.10.1 255.255.255.252
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 172.16.10.2 remote-as 65001 // Ini ASN Customer
neighbor 172.16.10.2 default-originate // Kirim Default Route ke Customer Via BGP
neighbor 172.16.10.2 version 4
neighbor 172.16.10.2 prefix-list 10 in // Terima network yang masuk dg prefix /24
lanjut

ip nat inside source list 101 interface FastEthernet0/0 overload
ip nat inside source static tcp 172.16.10.2 23 interface FastEthernet0/0 231
ip route 0.0.0.0 0.0.0.0 10.8.8.1
ip prefix-list 10 description customer_in
ip prefix-list 10 seq 5 permit 10.1.1.0/24 le 32
access-list 101 permit ip 172.16.0.0 0.0.255.255 any
access-list 101 permit ip any 172.16.0.0 0.0.255.255

Config R8

interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0

interface FastEthernet1/0
description To R0
ip address 172.16.10.2 255.255.255.252
!
router bgp 65001
no synchronization
bgp log-neighbor-changes
neighbor 172.16.10.1 remote-as 65000
neighbor 172.16.10.1 default-originate
neighbor 172.16.10.1 version 4
neighbor 172.16.10.1 prefix-list 20 out
!
ip route 0.0.0.0 0.0.0.0 172.16.10.1 23 name Aletrnate_route_to_R0
!
ip prefix-list 20 description Allowed LAN
ip prefix-list 20 seq 5 permit 10.1.1.0/24

Kita lihat output routing BGP nya..

R8 / Customer
R8#sh ip route bgp
B* 0.0.0.0/0 [20/0] via 172.16.10.1, 00:11:12

R8#sh ip bgp neighbors 172.16.10.1 ad
Originating default network 0.0.0.0

R8#sh ip bgp neighbors 172.16.10.1 routes
Network Next Hop Metric LocPrf Weight Path
*> 0.0.0.0 172.16.10.1 0 65000 i

OK segitu dulu ya,, besok lanjut lagi achh…he..he..Semoga Bermanfaat..

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s