Dual BGP with AS prepend (Redundancy)

Posted: February 15, 2010 in BGP, Cisco, Networking

Capture By Wiwid

Config Router-6
interface FastEthernet0/0
ip address 172.16.10.2 255.255.255.0
!
interface FastEthernet1/0
ip address 172.16.70.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 172.16.60.1 255.255.255.0
!
router bgp 212
no synchronization
bgp log-neighbor-changes
network 172.16.60.0 mask 255.255.255.0
neighbor 172.16.10.1 remote-as 234
neighbor 172.16.10.1 version 4
neighbor 172.16.10.1 prefix-list 10 out
neighbor 172.16.10.1 route-map traf_inbound in
neighbor 172.16.10.1 route-map traf_inbound out
neighbor 172.16.10.1 filter-list 100 out
neighbor 172.16.70.1 remote-as 235
neighbor 172.16.70.1 version 4
neighbor 172.16.70.1 prefix-list 10 out
neighbor 172.16.70.1 filter-list 100 out

ip as-path access-list 100 permit ^V
ip prefix-list 10 seq 10 permit 172.16.60.0/24

route-map traf_inbound permit 100
set as-path prepend 212 212
!
route-map traf_outbond permit 100
set as-path prepend 212 212

Config Router-7
interface FastEthernet0/0
ip address 10.8.8.239 255.255.255.0
!
interface FastEthernet1/0
ip address 172.16.70.1 255.255.255.0
!
router bgp 235
no synchronization
bgp log-neighbor-changes
neighbor 172.16.70.2 remote-as 212
neighbor 172.16.70.2 default-originate
neighbor 172.16.70.2 version 4
neighbor 172.16.70.2 distribute-list 20 out

ip route 0.0.0.0 0.0.0.0 10.8.8.1

Config Router-0
interface FastEthernet0/0
ip address 10.8.8.238 255.255.255.0
!
interface FastEthernet1/0
ip address 172.16.10.1 255.255.255.0
!
interface FastEthernet2/0
ip address 172.16.20.1 255.255.255.0

router bgp 234
no synchronization
bgp log-neighbor-changes
neighbor 172.16.10.2 remote-as 212
neighbor 172.16.10.2 default-originate
neighbor 172.16.10.2 version 4
neighbor 172.16.10.2 distribute-list 20 out

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s