Basics MPLS FRAME MODE

Posted: June 28, 2010 in Uncategorized

Multi Protocol Label Switching adalah sebuah teknologi baru yang bertujuan untuk memberikan alternatif lain dalam proses pengiriman paket pada suatu jaringan yaitu dengan menggabungkan teknologi switching/forwarding di layer 2 dengan teknologi routing di layer 3. Dengan memberikan label atau pengelompokan untuk setiap protocol diharapkan mengurangi network congestion (kemacetan). Di MPLS, bisa dibilang ada 2 domain, Core dan Edge. Setiap node nya disebut LSR (Label Switching Routers). Untuk pemahaman apa itu MPLS, dan apa aja item pendukungnya tanya Mba Google aja ya..he.h.e.he. ok langsung aja, berikut simulasi MPLSnya. Namanya jg belajar, he.h.eeh.CEKIDOT…

Learning By Doing Aja

lanjut

Konfigurasi umum untuk basic MPLS, kurang lebih seperti ini.
1. Enable CEF (Cisco Express Forwarding)
2. Konfigurasi protocol routingnya, pake OSPF aja kali ya…
3. Define LDP (Label Distribution Protocol)
4. LDP Router-ID
5. Konfigurasi interface MPLS

KOnfigurasi Router Cisco nya kurang lebih seperti ini :

Router-0
ip cef
mpls label protocol ldp

interface Loopback0
ip address 10.10.10.1 255.255.255.255
!
interface FastEthernet0/0
description To R1
ip address 172.16.10.1 255.255.255.252
mpls ip
!
interface FastEthernet0/1
description To R4
ip address 172.16.40.1 255.255.255.252
mpls ip

router ospf 212
log-adjacency-changes
network 10.10.10.0 0.0.0.255 area 0
network 172.16.10.0 0.0.0.3 area 0
network 172.16.40.0 0.0.0.3 area 0

mpls ldp router-id Loopback0

Router-1
ip cef
mpls label protocol ldp

interface Loopback0
ip address 10.10.10.2 255.255.255.255
!
interface FastEthernet0/0
description To R0
ip address 172.16.10.2 255.255.255.252
mpls ip
!
interface FastEthernet0/1
description To R2
ip address 172.16.20.1 255.255.255.252
mpls ip

router ospf 212
log-adjacency-changes
network 10.10.10.0 0.0.0.255 area 0
network 172.16.10.0 0.0.0.3 area 0
network 172.16.20.0 0.0.0.3 area 0

mpls ldp router-id Loopback0

Router-2
ip cef
mpls label protocol ldp

interface Loopback0
ip address 10.10.10.3 255.255.255.255
!
interface FastEthernet0/0
description To R3
ip address 172.16.30.1 255.255.255.252
mpls ip
!
interface FastEthernet0/1
description To R1
ip address 172.16.20.2 255.255.255.252
mpls ip

router ospf 212
log-adjacency-changes
network 10.10.10.0 0.0.0.255 area 0
network 172.16.20.0 0.0.0.3 area 0
network 172.16.30.0 0.0.0.3 area 0

mpls ldp router-id Loopback0

Router-3
ip cef
mpls label protocol ldp

interface Loopback0
ip address 10.10.10.4 255.255.255.255
!
interface FastEthernet0/0
description To R2
ip address 172.16.30.2 255.255.255.252
mpls ip
!
interface FastEthernet0/1
description To R5
ip address 172.16.50.1 255.255.255.252
mpls ip

router ospf 212
log-adjacency-changes
network 10.10.10.0 0.0.0.255 area 0
network 172.16.50.0 0.0.0.3 area 0
network 172.16.30.0 0.0.0.3 area 0

mpls ldp router-id Loopback0

Router-4
interface Loopback0
ip address 10.10.10.5 255.255.255.255
!
interface FastEthernet0/0
description To R0
ip address 172.16.40.2 255.255.255.252

router ospf 212
log-adjacency-changes
network 10.10.10.0 0.0.0.255 area 0
network 172.16.40.0 0.0.0.3 area 0

OK Sekarang coba test MPLS nya…Dari Router-4 Ping atau Traceroute ke Router-3

Router-4#traceroute 10.10.10.4
1 172.16.40.1 36 msec 16 msec 16 msec
2 172.16.10.2 [MPLS: Label 22 Exp 0] 64 msec 32 msec 28 msec
3 172.16.20.2 68 msec 20 msec 16 msec
4 172.16.30.2 44 msec 44 msec *

OK Coba kita lihat bagaimana MPLS ini bekerja, dg cara menggunakan command “show mpls forwarding-table. Kita ambil contoh, kita mau tahu aliran packet dari Router-4 ke Router-3 (loopback 10.10.10.4/32).

Router-0#show mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Pop tag 10.10.10.2/32 0 Fa0/0 172.16.10.2
17 Pop tag 172.16.20.0/30 0 Fa0/0 172.16.10.2
18 19 10.10.10.3/32 0 Fa0/0 172.16.10.2
19 18 172.16.30.0/30 0 Fa0/0 172.16.10.2
20 22 10.10.10.4/32 0 Fa0/0 172.16.10.2
21 16 172.16.50.0/30 0 Fa0/0 172.16.10.2
22 21 10.10.10.6/32 0 Fa0/0 172.16.10.2
23 Untagged 10.10.10.5/32 0 Fa0/1 172.16.40.2

Bisa dilihat, bahwa network 10.10.10.4/32 atau ip loopback Router-4 menggunakan label outgoing 22

Sampe di Router-1, maka label outgoingnya berubah
Router-1#show mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Untagged 172.16.50.0/30 0 Fa0/1 172.16.20.2
17 Pop tag 172.16.40.0/30 0 Fa0/0 172.16.10.1
18 Untagged 172.16.30.0/30 0 Fa0/1 172.16.20.2
19 Untagged 10.10.10.3/32 734 Fa0/1 172.16.20.2
20 Pop tag 10.10.10.1/32 0 Fa0/0 172.16.10.1
21 Untagged 10.10.10.6/32 378 Fa0/1 172.16.20.2
22 Untagged 10.10.10.4/32 1392 Fa0/1 172.16.20.2
23 23 10.10.10.5/32 0 Fa0/0 172.16.10.1

outgoing untagged maksudnya, tidak ada label switching yang aktif pada interface outgouing. atau tidak ada label dari tujuan dari hop berikutnya

Router-2
Router-2#show mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Pop tag 172.16.50.0/30 0 Fa0/0 172.16.30.2
17 Untagged 172.16.40.0/30 710 Fa0/1 172.16.20.1
18 Untagged 172.16.10.0/30 0 Fa0/1 172.16.20.1
19 Untagged 10.10.10.2/32 0 Fa0/1 172.16.20.1
20 Untagged 10.10.10.1/32 0 Fa0/1 172.16.20.1
21 22 10.10.10.6/32 0 Fa0/0 172.16.30.2
22 Pop tag 10.10.10.4/32 0 Fa0/0 172.16.30.2

POP Tag artinya, ip address berikutnya akan dimunculkan ke tujuan router selanjutnya…(he.he.h.e)

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s