HSRP (Primary/Backup)

Posted: March 8, 2011 in Cisco, Networking

Bro n Sista, ane lagi simulasi HSRP. Karena Bro n Sista sudah banyak yang tau,, Secara umum, protokol ini propertynya Cisco, konsepnya hampir sama dengan fail over/redundant link. Hanya disini, terdapat virtual router sebagai gateway dari host. Dan untuk menentukan primary/backup dengan set priority.
Network diagramnya seperti berikut

HSRP By Wiwid


Untuk routingnya ane pake OSPF ya..
Berikut konfigurasi routernya

Router-1 :
interface FastEthernet0/0
description To SW1 (F0/1)
ip address 172.16.10.3 255.255.255.248
standby 10 ip 172.16.10.1
standby 10 preempt
standby 10 name HSRP_10
standby 10 track FastEthernet0/1

interface FastEthernet0/1
description Router-JKT (F1/0)
ip address 172.16.20.1 255.255.255.248

router ospf 212
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 212

Router-2
interface FastEthernet0/0
description To SW1 (F0/2)
ip address 172.16.10.2 255.255.255.248
standby 10 ip 172.16.10.1
standby 10 priority 50
standby 10 preempt
standby 10 name HSRP_10
standby 10 track FastEthernet1/0
!
interface FastEthernet0/1
description To Router-3 (F0/0)
ip address 172.16.30.1 255.255.255.248

router ospf 212
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 212

Router-3

interface FastEthernet0/0
description To Router-2 (F0/1)
ip address 172.16.30.2 255.255.255.248
!interface FastEthernet0/1
description To Router-1 (F0/1)
ip address 172.16.20.2 255.255.255.248
!
interface FastEthernet1/0
description To Router-5 (F1/0)
ip address 192.168.70.1 255.255.255.248

router ospf 212
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 212
network 192.168.70.0 0.0.0.255 area 212

Router-4

interface FastEthernet0/0
Description To HSRP
ip address 172.16.10.4 255.255.255.248

router ospf 212
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 212

Router-5

interface FastEthernet0/0
ip address 192.168.70.2 255.255.255.248

router ospf 212
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 212
network 192.168.70.0 0.0.0.255 area 212

Testing
Traceroute From Router-5 Fo Router-4 Via Router-2 (Main Link)

Router-5#traceroute 172.16.10.4
Type escape sequence to abort.
Tracing the route to 172.16.10.4

1 192.168.70.1 8 msec 8 msec 12 msec
2 172.16.30.1 0 msec 20 msec 28 msec
3 172.16.10.4 40 msec 4 msec *

Traceroute from Router5 To Router4 , jika F0/0 Router-2 dishutdown

Router-5#traceroute 172.16.10.4
1 192.168.70.1 112 msec 28 msec 12 msec
2 172.16.20.1 272 msec 4 msec 20 msec
3 172.16.10.4 116 msec 44 msec *

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s