OSPF Multi Area With STUB

Posted: April 28, 2011 in Cisco, OSPF

Bro n Sista,

Stub Area kl ga salah itu area paling ujung dan tidak bercabang. Area jenis ini memiliki karakteristik tidak menerima LSA tipe 4 dan 5. Artinya adalah area jenis ini tidak menerima paket LSA yang berasal dari area lain yang dihantarkan oleh router ABR dan tidak menerima paket LSA yang berasal dari routing protokol lain yang keluar dari router ASBR (LSA tipe 4 dan 5). Jadi dengan kata lain, router ini hanya menerima informasi dari router-router lain yang berada dalam satu area, tidak ada informasi routing baru di router. CMIIW ya..

Network diagramnya kurang lebih spt ini..

Created By Wiwid

Konfigurasinya, simple bro n sita jg sdh pada tau.
R1

interface Loopback0
ip address 172.16.100.1 255.255.255.255
!
interface FastEthernet0/0
description To R2 (F1/0)
ip address 192.168.20.2 255.255.255.252

router ospf 2011
router-id 172.16.100.1
log-adjacency-changes
area 200 stub no-summary
network 172.16.100.0 0.0.0.255 area 200
network 192.168.20.0 0.0.0.3 area 200


R2

interface Loopback0
ip address 172.16.100.2 255.255.255.255
!
interface FastEthernet0/0
description to R4 (f0/0)
ip address 172.16.10.2 255.255.255.252

interface FastEthernet0/1
description To R5 (f0/0)
ip address 172.16.30.1 255.255.255.252

interface FastEthernet1/0
ip address 192.168.20.1 255.255.255.252

router ospf 2011
router-id 172.16.100.2
log-adjacency-changes
area 200 stub no-summary
network 172.16.10.0 0.0.0.3 area 0
network 172.16.30.0 0.0.0.3 area 0
network 172.16.100.0 0.0.0.255 area 0
network 192.168.20.0 0.0.0.3 area 200

R3

interface Loopback0
ip address 172.16.100.3 255.255.255.255
!
interface FastEthernet0/0
description to R4 (f1/0)
ip address 192.168.10.2 255.255.255.252

router ospf 2011
router-id 172.16.100.3
log-adjacency-changes
area 0 virtual-link 172.16.100.5
area 100 stub no-summary
network 172.16.100.0 0.0.0.255 area 100
network 192.168.10.0 0.0.0.3 area 100

R4

interface Loopback0
ip address 172.16.100.4 255.255.255.255
!
interface FastEthernet0/0
description To R2 (f0/0)
ip address 172.16.10.1 255.255.255.252

interface FastEthernet0/1
description To R5 (f1/0)
ip address 172.16.20.1 255.255.255.252

interface FastEthernet1/0
description To R3 (f0/0)
ip address 192.168.10.1 255.255.255.252

router ospf 2011
router-id 172.16.100.4
log-adjacency-changes
area 100 stub no-summary
summary-address 192.168.10.0 255.255.255.252
network 172.16.10.0 0.0.0.3 area 0
network 172.16.20.0 0.0.0.3 area 0
network 172.16.100.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.3 area 100

R5

interface Loopback0
ip address 172.16.100.5 255.255.255.255
!
interface FastEthernet0/0
description to R2 (f0/1)
ip address 172.16.30.2 255.255.255.252

interface FastEthernet0/1
description tO R6 (F0/0)
ip address 192.168.30.1 255.255.255.252

interface FastEthernet1/0
description To R4 (F0/1)
ip address 172.16.20.2 255.255.255.252

router ospf 2011
router-id 172.16.100.5
log-adjacency-changes
area 300 stub no-summary
network 172.16.20.0 0.0.0.3 area 0
network 172.16.30.0 0.0.0.3 area 0
network 172.16.100.0 0.0.0.255 area 300
network 192.168.30.0 0.0.0.3 area 300

R6

interface Loopback0
ip address 172.16.100.6 255.255.255.255
!
interface FastEthernet0/0
description to R5 (f0/1)
ip address 192.168.30.2 255.255.255.252

router ospf 2011
log-adjacency-changes
area 300 stub no-summary
network 172.16.100.0 0.0.0.255 area 300
network 192.168.30.0 0.0.0.3 area 300

Testing STUB,,
dengan command ” sh ip ro ospf”. Untuk area selain 0, menggunakan STUB semua yaitu R1, R3, dan R6

R6#sh ip ro os
172.16.0.0/32 is subnetted, 2 subnets
O 172.16.100.5 [110/11] via 192.168.30.1, 00:36:55, FastEthernet0/0
O*IA 0.0.0.0/0 [110/11] via 192.168.30.1, 00:36:55, FastEthernet0/0

Jika tidak menggunakan STUB, hasilnya akan seperti ini. Network2 lain dari area lain akan diterima

R6#sh ip ro os
192.168.10.0/30 is subnetted, 1 subnets
O IA 192.168.10.0 [110/12] via 192.168.30.1, 00:02:45, FastEthernet0/0
172.16.0.0/16 is variably subnetted, 9 subnets, 2 masks
O IA 172.16.30.0/30 [110/20] via 192.168.30.1, 00:02:45, FastEthernet0/0
O IA 172.16.20.0/30 [110/11] via 192.168.30.1, 00:02:45, FastEthernet0/0
O IA 172.16.10.0/30 [110/21] via 192.168.30.1, 00:02:45, FastEthernet0/0
O IA 172.16.100.1/32 [110/22] via 192.168.30.1, 00:02:45, FastEthernet0/0
O IA 172.16.100.2/32 [110/21] via 192.168.30.1, 00:02:45, FastEthernet0/0
O IA 172.16.100.3/32 [110/13] via 192.168.30.1, 00:02:45, FastEthernet0/0
O IA 172.16.100.4/32 [110/12] via 192.168.30.1, 00:02:45, FastEthernet0/0
O 172.16.100.5/32 [110/11] via 192.168.30.1, 00:02:45, FastEthernet0/0
192.168.20.0/30 is subnetted, 1 subnets
O IA 192.168.20.0 [110/21] via 192.168.30.1, 00:02:45, FastEthernet0/0
O*IA 0.0.0.0/0 [110/11] via 192.168.30.1, 00:02:45, FastEthernet0/0

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s