RIP ON JUNOS…

Posted: July 26, 2011 in Juniper, Networking

Alhamdulillah,,
Akhirnya bisa juga, configuration RIP on JUNOS. Beda vendor beda config ya.he.he.he.
kalo di Cisco cukup masukan networknya saja. Tapi, di Junos yang didaftarkan yaitu interface directly. Eits ga sampe disitu aja, perlu diexport lagi. Interface atau network selain interface directly RIP. CMIIW

Design By Wiwid



wiwid@my_junos# run show configuration logical-routers
R1 {
interfaces {
fxp1 {
unit 1 {
vlan-id 10;
family inet {
address 172.16.10.1/29;
}
}
unit 2 {
vlan-id 40;
family inet {
address 10.10.10.1/30;
}
}
}
lo0 {
unit 1 {
family inet {
address 10.1.1.1/32;
}
}
}
}
protocols {
rip {
group RIP_Group {
export RIP_Routes;
neighbor fxp1.1;
neighbor lo0.1;
neighbor fxp1.2;
}
}
}
policy-options {
policy-statement RIP_Routes {
term ADVERTISE {
from protocol [ rip direct ];
then accept;
}
}
}
}
R2 {
interfaces {
fxp2 {
unit 1 {
vlan-id 10;
family inet {
address 172.16.10.2/29;
}
}
unit 2 {
vlan-id 20;
family inet {
address 10.5.5.1/30;
}
}
}
lo0 {
unit 2 {
family inet {
address 10.1.1.2/32;
}
}
}
}
protocols {
rip {
group RIP_Group {
export RIP_Routes;
neighbor fxp2.1;
neighbor fxp2.2;
neighbor lo0.2;
}
}
}
policy-options {
policy-statement RIP_Routes {
term ADVERTISE {
from protocol [ direct rip ];
then accept;
}
}
}
}
R3 {
interfaces {
fxp3 {
unit 1 {
vlan-id 40;
family inet {
address 10.10.10.2/30;
}
}
unit 2 {
vlan-id 30;
family inet {
address 172.16.20.1/29;
}
}
}
lo0 {
unit 3 {
family inet {
address 10.1.1.3/32;
}
}
}
}
protocols {
rip {
group RIP_Group {
export RIP_Routes;
neighbor fxp3.1;
neighbor fxp3.2;
neighbor lo0.3;
}
}
}
policy-options {
policy-statement RIP_Routes {
term ADVERTISE {
from protocol [ direct rip ];
then accept;
}
}
}
}
R4 {
interfaces {
fxp4 {
unit 1 {
vlan-id 30;
family inet {
address 172.16.20.2/29;
}
}
unit 2 {
vlan-id 20;
family inet {
address 10.5.5.2/30;
}
}
}
lo0 {
unit 4 {
family inet {
address 10.1.1.4/32;
}
}
}
}
protocols {
rip {
group RIP_Group {
export RIP_Routes;
neighbor fxp4.1;
neighbor fxp4.2;
neighbor lo0.4;
}
}
}
policy-options {
policy-statement RIP_Routes {
term ADVERTISE {
from protocol [ direct rip ];
then accept;
}
}
}
}

Coba kita verify ya,, using command “show route protocol rip” dan “show rip neighbor”
Kita ambil sample yaitu R1

wiwid@my_junos# run show route protocol rip logical-router R1
inet.0: 11 destinations, 11 routes (11 active, 0 holddown, 0 hidden)
+ = Active Route, – = Last Active, * = Both

10.1.1.2/32 *[RIP/100] 00:47:06, metric 2, tag 0
> to 172.16.10.2 via fxp1.1
10.1.1.3/32 *[RIP/100] 00:39:25, metric 2, tag 0
> to 10.10.10.2 via fxp1.2
10.1.1.4/32 *[RIP/100] 00:36:34, metric 3, tag 0
> to 172.16.10.2 via fxp1.1
to 10.10.10.2 via fxp1.2
10.5.5.0/30 *[RIP/100] 00:47:06, metric 2, tag 0
> to 172.16.10.2 via fxp1.1
172.16.20.0/29 *[RIP/100] 00:39:25, metric 2, tag 0
> to 10.10.10.2 via fxp1.2
224.0.0.9/32 *[RIP/100] 00:36:40, metric 1
MultiRecv
Penjelasan, jika kita tidak menambahkan policy statement pada protocol RIP. Maka show route protocol rip. Hanya ada network directly saja, seperti tabel dibawah

wiwid@my_junos# run show route protocol rip logical-router R1
inet.0: 6 destinations, 6 routes (6 active, 0 holddown, 0 hidden)
+ = Active Route, – = Last Active, * = Both

224.0.0.9/32 *[RIP/100] 00:04:35, metric 1
MultiRecv

wiwid@my_junos# run show rip neighbor logical-router R1
Source Destination Send Receive In
Neighbor State Address Address Mode Mode Met
——– —– ——- ———– —- ——- —
fxp1.2 Up 10.10.10.1 224.0.0.9 mcast both 1
lo0.1 Up 10.1.1.1 224.0.0.9 mcast both 1
fxp1.1 Up 172.16.10.1 224.0.0.9 mcast both 1

IP 224.0.0.9 merupakan ip multicast RIP.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s