Archive for the ‘Juniper’ Category

Berikut simulasi redistribute OSPF into BGP. Ada beberapa trik agar labs simulasi ini bisa berjalan.
Karena nilai AD atau preference OSPF lebih kecil dari preference BGP. Maka, kita harus manipulasi nilai AD/Preference OSPF lebih besar dibanding preference BGP. CMIIW. Berikut network simulasinya..

Design By Wiwid

Konfigurasi R1 :

[edit logical-routers r1]

Konfigurasi R1

Konfigurasi R2 :

Konfigurasi R2_Interfaces

Konfigurasi R2_Protocols

Konfigurasi R2_Policy

Verifikasi cek show route ip loopback R3 dari R1.

show route ip loopback r3 from r1

Advertisements

Dalam simulasi lab ini, redistribute static to ospf. Dimana R1 dan R5 mempunyai default route.
Dan R2,R3,R4 menggunakan protocol OSPF dengan area 0. Untuk verifikasinya, dengan cara ping dari router R1 ke R5 atau sebaliknya.

Konfigurasi R1

Konfigurasi R2

Konfigurasi R3
</a
Konfigurasi R4

Konfigurasi R5

Ping R1 ke R5

wiwid@jkt-home-jnp# …ping 172.16.40.2 logical-router r1 rapid count 50
PING 172.16.40.2 (172.16.40.2): 56 data bytes
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
— 172.16.40.2 ping statistics —
50 packets transmitted, 50 packets received, 0% packet loss
round-trip min/avg/max/stddev = 1.203/2.333/24.358/3.677 ms

Ping R5 ke R1

wiwid@jkt-home-jnp# run ping 172.16.10.2 logical-router r5 rapid count 50
PING 172.16.10.2 (172.16.10.2): 56 data bytes
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
— 172.16.10.2 ping statistics —
50 packets transmitted, 50 packets received, 0% packet loss
round-trip min/avg/max/stddev = 1.208/4.105/78.250/11.071 ms

Virtual-link OSPF On Junos

Posted: September 28, 2011 in Juniper, Networking

Seperti halnya Virtual-link OSPF on Cisco, di Junos pun hampir sama. Tujuan Virtual-link ini adalah untuk memanipulasi router yang berada diluar area0, atau terhubung dengan area lain. Tapi, seakan-akan router tersebut terhubung dengan Area0.
Network Diagramnya sebagai berikut..simulasi melalui Olive. Sehingga, menggunakan logical-router..
Design By Wiwid

Untuk konfigurasinya silahkan download
Config_R1
Config_R2
Config_R3
Config_R4

Jika virtual-link antara R1 & R3 tidak ada (deactivate), maka neighbor router R1, hanya R2 & R3
wiwid@my_junos# run show ospf neighbor logical-router R1
Address Interface State ID Pri Dead
10.50.50.2 fxp1.1 Full 10.1.1.20 128 37
10.11.10.2 fxp1.2 Full 10.1.1.30 128 37

Jika virtual-link diaktifkan, maka neighbor di R1 akan bertambah
wiwid@my_junos# run show ospf neighbor logical-router R1
Address Interface State ID Pri Dead
10.50.50.2 fxp1.1 Full 10.1.1.20 128 36
10.11.10.2 vl-10.1.1.30 Full 10.1.1.30 0 36
10.11.10.2 fxp1.2 Full 10.1.1.30 128 36

vl=virtual-link

Ping dari R4 – R2, hasilnya sbb :
wiwid@my_junos# run ping 10.1.1.20 logical-router R4
PING 10.1.1.20 (10.1.1.20): 56 data bytes
64 bytes from 10.1.1.20: icmp_seq=0 ttl=62 time=3.497 ms
64 bytes from 10.1.1.20: icmp_seq=1 ttl=62 time=2.372 ms
64 bytes from 10.1.1.20: icmp_seq=2 ttl=62 time=1.508 ms

^C

Export RIP To OSPF

Posted: July 26, 2011 in Juniper, Networking

Istilah Redistributed di Junos adalah “export” yaitu membawa/melewati protocol routing lain, ke dalam protocol routing lainnya.

Berikut configurationnya…Silahkan download ya…
RIP To OSPF

Jika dilihat “show route” di Router-4, maka terdapat routing table OSPF dan RIP..

wiwid@my_junos# run show route logical-router R4

inet.0: 15 destinations, 15 routes (15 active, 0 holddown, 0 hidden)
+ = Active Route, – = Last Active, * = Both

10.1.1.1/32 *[RIP/100] 00:06:57, metric 3, tag 0
> to 172.16.20.1 via fxp4.1
to 10.5.5.1 via fxp4.2
10.1.1.2/32 *[RIP/100] 00:07:01, metric 2, tag 0
> to 10.5.5.1 via fxp4.2
10.1.1.3/32 *[RIP/100] 00:06:42, metric 2, tag 0
> to 172.16.20.1 via fxp4.1
10.1.1.4/32 *[Direct/0] 02:04:50
> via lo0.4
10.1.1.5/32 *[OSPF/10] 00:10:40, metric 1
> to 10.7.7.2 via fxp4.3
10.5.5.0/30 *[Direct/0] 02:04:50
> via fxp4.2
10.5.5.2/32 *[Local/0] 02:04:50
Local via fxp4.2
10.7.7.0/30 *[Direct/0] 00:11:28
> via fxp4.3
10.7.7.1/32 *[Local/0] 00:11:28
Local via fxp4.3
10.10.10.0/30 *[RIP/100] 00:06:42, metric 2, tag 0
> to 172.16.20.1 via fxp4.1
172.16.10.0/29 *[RIP/100] 00:07:01, metric 2, tag 0
> to 10.5.5.1 via fxp4.2
172.16.20.0/29 *[Direct/0] 02:04:50
> via fxp4.1
172.16.20.2/32 *[Local/0] 02:04:50
Local via fxp4.1
224.0.0.5/32 *[OSPF/10] 00:11:27, metric 1
MultiRecv
224.0.0.9/32 *[RIP/100] 00:01:48, metric 1
MultiRecv

RIP ON JUNOS…

Posted: July 26, 2011 in Juniper, Networking

Alhamdulillah,,
Akhirnya bisa juga, configuration RIP on JUNOS. Beda vendor beda config ya.he.he.he.
kalo di Cisco cukup masukan networknya saja. Tapi, di Junos yang didaftarkan yaitu interface directly. Eits ga sampe disitu aja, perlu diexport lagi. Interface atau network selain interface directly RIP. CMIIW

Design By Wiwid


(more…)

Static Route di Junos sangat menarik ya…

Design By Wiwid

Confignya :
R1

wiwid@my-junos# run show configuration logical-routers R1
interfaces {
fxp1 {
unit 1 {
vlan-id 50;
family inet {
address 10.0.11.1/30;
}
}
unit 2 {
vlan-id 60;
family inet {
address 10.0.80.1/30;
}
}
}
lo0 {
unit 1 {
family inet {
address 172.16.10.1/32;
}
}
}
}
routing-options {
static {
route 10.0.15.0/30 next-hop 10.0.11.2;
}
}

lanjut
(more…)

bro n Sis, kali ini gue mw publish. Hasil oleh2 ngelab “JNCIP STUDY Group” bareng anak2 IDN.
Cekidot ya…

Created By Wiwid

Konfigurasi routernya kurang lebih spt dibawah ini :

Router-1

set interfaces fxp1.1 family inet address 10.0.11.1/30
set interfaces fxp1.2 family inet address 10.0.80.1/30
set protocols ospf area 0.0.0.1 interface fxp1.1
set protocols ospf area 0.0.0.1 interface fxp1.2
set protocols ospf area 0.0.0.1 interface lo0.10 passive
set interfaces fxp1.1 vlan-id 10
set interfaces fxp1.2 vlan-id 12
edit interfaces lo0.10 family inet address 172.16.10.1/32

Router-2

set interfaces fxp2.1 family inet address 10.0.11.2/30
set interfaces fxp2.2 family inet address 10.0.18.1/30
set interfaces fxp2.3 family inet address 10.0.15.1/30
set protocols ospf area 0.0.0.1 interface fxp2.1
set protocols ospf area 0.0.0.0 interface fxp2.2
set protocols ospf area 0.0.0.0 interface fxp2.2
set protocols ospf area 0.0.0.0 interface lo0.11 passive
set interfaces fxp2.1 vlan-id 10
set interfaces fxp2.2 vlan-id 12
set interfaces fxp2.3 vlan-id 13
edit interfaces lo0.11 family inet address 172.16.10.2/32

Router-3

set interfaces fxp3.1 family inet address 10.0.80.2/30
set interfaces fxp3.2 family inet address 10.0.18.2/30
set interfaces fxp3.3 family inet address 10.0.70.1/30
set protocols ospf area 0.0.0.1 interface fxp3.1
set protocols ospf area 0.0.0.0 interface fxp3.2
set protocols ospf area 0.0.0.0 interface fxp3.2
set protocols ospf area 0.0.0.0 interface lo0.12 passive
set interfaces fxp3.1 vlan-id 11
set interfaces fxp3.2 vlan-id 12
set interfaces fxp3.3 vlan-id 14
edit interfaces lo0.12 family inet address 172.16.10.5/32
(more…)