Archive for the ‘OSPF’ Category

Sore Bro n Sis,

Alhamdulillah, running well jg simulasi “OSPF Virtual Link”
langsung aja ya. Berikut network diagram dan konfigurasinya

Design By Wiwid

R2 :
interface Loopback0
ip address 172.16.1.2 255.255.255.255

interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 2000000
frame-relay lmi-type ansi
!
interface Serial0/0.101 point-to-point
ip address 192.168.1.1 255.255.255.248
snmp trap link-status
frame-relay interface-dlci 101
!
interface Serial0/0.102 point-to-point
ip address 192.168.2.1 255.255.255.248
snmp trap link-status
frame-relay interface-dlci 102
!
interface Serial0/0.103 point-to-point
ip address 192.168.3.1 255.255.255.248
snmp trap link-status
frame-relay interface-dlci 103
!
interface FastEthernet0/1
description to R7 (F0/1)
ip address 10.10.7.1 255.255.255.252

router ospf 99
router-id 172.16.1.2
log-adjacency-changes
area 20 virtual-link 172.16.1.7
network 10.10.7.0 0.0.0.3 area 20
network 172.16.1.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.7 area 0
network 192.168.2.0 0.0.0.7 area 0
network 192.168.3.0 0.0.0.7 area 0

R3 :
interface Loopback0
ip address 172.16.1.3 255.255.255.255

interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 2000000
frame-relay lmi-type ansi
!
interface Serial0/0.101 point-to-point
ip address 192.168.1.2 255.255.255.248
snmp trap link-status
frame-relay interface-dlci 101
!
router ospf 99
router-id 172.16.1.3
log-adjacency-changes
network 172.16.1.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.7 area 0

R4 :
interface Loopback0
ip address 172.16.1.4 255.255.255.255
!
interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 2000000
frame-relay lmi-type ansi
!
interface Serial0/0.102 point-to-point
ip address 192.168.2.2 255.255.255.248
snmp trap link-status
frame-relay interface-dlci 102
!
router ospf 99
router-id 172.16.1.4
log-adjacency-changes
network 172.16.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0

R5 :
interface Loopback0
ip address 172.16.1.5 255.255.255.255
!
interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 2000000
frame-relay lmi-type ansi
!
interface Serial0/0.103 point-to-point
ip address 192.168.3.2 255.255.255.248
snmp trap link-status
frame-relay interface-dlci 103
!
router ospf 99
router-id 172.16.1.5
log-adjacency-changes
network 172.16.1.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.7 area 0

R5 :

interface Loopback0
ip address 172.16.1.5 255.255.255.255
!
interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 2000000
frame-relay lmi-type ansi
!
interface Serial0/0.103 point-to-point
ip address 192.168.3.2 255.255.255.248
snmp trap link-status
frame-relay interface-dlci 103
!
router ospf 99
router-id 172.16.1.5
log-adjacency-changes
network 172.16.1.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.7 area 0

R7 :
interface Loopback0
ip address 172.16.1.7 255.255.255.255
!
interface FastEthernet0/0
description To R8 (F0/0)
ip address 10.10.150.1 255.255.255.252
!
interface FastEthernet0/1
description To R2 (F0/1)
ip address 10.10.7.2 255.255.255.252

router ospf 99
router-id 172.16.1.7
log-adjacency-changes
area 20 virtual-link 172.16.1.2
network 10.10.7.0 0.0.0.3 area 20
network 10.10.150.0 0.0.0.3 area 30
network 172.16.1.0 0.0.0.255 area 20

R8 :
interface Loopback0
ip address 172.16.1.8 255.255.255.255
!
interface FastEthernet0/0
description To R7 (F0/0)
ip address 10.10.150.2 255.255.255.252

router ospf 99
router-id 172.16.1.8
log-adjacency-changes
network 10.10.150.0 0.0.0.3 area 30
network 172.16.1.0 0.0.0.255 area 30

NOTE :
Verifikasi apakah virtual-link dengan baik. Cek “show ip route di R8”, karena R8 tidak terhubung langsung dengan AREA 0. Jika di R8, terdapat routing-table dari “inter-area (IA)” maka virtual-link sudah UP.

R8#sh ip ro ospf
172.16.0.0/32 is subnetted, 5 subnets
O IA 172.16.1.5 [110/85] via 10.10.150.1, 00:16:01, FastEthernet0/0
O IA 172.16.1.4 [110/85] via 10.10.150.1, 00:16:01, FastEthernet0/0
O IA 172.16.1.7 [110/11] via 10.10.150.1, 00:16:11, FastEthernet0/0
O IA 172.16.1.3 [110/85] via 10.10.150.1, 00:16:01, FastEthernet0/0
10.0.0.0/30 is subnetted, 2 subnets
O IA 10.10.7.0 [110/20] via 10.10.150.1, 00:16:11, FastEthernet0/0
192.168.1.0/29 is subnetted, 1 subnets
O IA 192.168.1.0 [110/84] via 10.10.150.1, 00:16:01, FastEthernet0/0
192.168.2.0/29 is subnetted, 1 subnets
O IA 192.168.2.0 [110/84] via 10.10.150.1, 00:16:01, FastEthernet0/0
192.168.3.0/29 is subnetted, 1 subnets
O IA 192.168.3.0 [110/84] via 10.10.150.1, 00:16:01, FastEthernet0/0

Advertisements

Dear RR
Sedikit berbagi di pagi hari.
Berikut PBR (Policy Base Routing) Versi Mikrotik Router, tujuannya untuk mereject/discard network yang tidak diperlukan, hasil advertised dari router lain. PBR ini cocok untuk User, selain bisa sbg preventif/firewall, mencegah paket broadcast dari User ke Internal kita.
Protocol yang saya pakai adalah OSPF, dengan chain yang dipakai ospf-in dan ospf-out
Network Diagramnya kurang lebih seperti dibawah ini
Wiwid
Silahkan Klik
(more…)

bro n Sis, kali ini gue mw publish. Hasil oleh2 ngelab “JNCIP STUDY Group” bareng anak2 IDN.
Cekidot ya…

Created By Wiwid

Konfigurasi routernya kurang lebih spt dibawah ini :

Router-1

set interfaces fxp1.1 family inet address 10.0.11.1/30
set interfaces fxp1.2 family inet address 10.0.80.1/30
set protocols ospf area 0.0.0.1 interface fxp1.1
set protocols ospf area 0.0.0.1 interface fxp1.2
set protocols ospf area 0.0.0.1 interface lo0.10 passive
set interfaces fxp1.1 vlan-id 10
set interfaces fxp1.2 vlan-id 12
edit interfaces lo0.10 family inet address 172.16.10.1/32

Router-2

set interfaces fxp2.1 family inet address 10.0.11.2/30
set interfaces fxp2.2 family inet address 10.0.18.1/30
set interfaces fxp2.3 family inet address 10.0.15.1/30
set protocols ospf area 0.0.0.1 interface fxp2.1
set protocols ospf area 0.0.0.0 interface fxp2.2
set protocols ospf area 0.0.0.0 interface fxp2.2
set protocols ospf area 0.0.0.0 interface lo0.11 passive
set interfaces fxp2.1 vlan-id 10
set interfaces fxp2.2 vlan-id 12
set interfaces fxp2.3 vlan-id 13
edit interfaces lo0.11 family inet address 172.16.10.2/32

Router-3

set interfaces fxp3.1 family inet address 10.0.80.2/30
set interfaces fxp3.2 family inet address 10.0.18.2/30
set interfaces fxp3.3 family inet address 10.0.70.1/30
set protocols ospf area 0.0.0.1 interface fxp3.1
set protocols ospf area 0.0.0.0 interface fxp3.2
set protocols ospf area 0.0.0.0 interface fxp3.2
set protocols ospf area 0.0.0.0 interface lo0.12 passive
set interfaces fxp3.1 vlan-id 11
set interfaces fxp3.2 vlan-id 12
set interfaces fxp3.3 vlan-id 14
edit interfaces lo0.12 family inet address 172.16.10.5/32
(more…)

OSPF Multi Area With STUB

Posted: April 28, 2011 in Cisco, OSPF

Bro n Sista,

Stub Area kl ga salah itu area paling ujung dan tidak bercabang. Area jenis ini memiliki karakteristik tidak menerima LSA tipe 4 dan 5. Artinya adalah area jenis ini tidak menerima paket LSA yang berasal dari area lain yang dihantarkan oleh router ABR dan tidak menerima paket LSA yang berasal dari routing protokol lain yang keluar dari router ASBR (LSA tipe 4 dan 5). Jadi dengan kata lain, router ini hanya menerima informasi dari router-router lain yang berada dalam satu area, tidak ada informasi routing baru di router. CMIIW ya..

Network diagramnya kurang lebih spt ini..

Created By Wiwid

Konfigurasinya, simple bro n sita jg sdh pada tau.
R1

interface Loopback0
ip address 172.16.100.1 255.255.255.255
!
interface FastEthernet0/0
description To R2 (F1/0)
ip address 192.168.20.2 255.255.255.252

router ospf 2011
router-id 172.16.100.1
log-adjacency-changes
area 200 stub no-summary
network 172.16.100.0 0.0.0.255 area 200
network 192.168.20.0 0.0.0.3 area 200

(more…)