bgp weight attribute

Posted: August 2, 2015 in Cisco

berikut simulasi lab bgp attributed menggunakan gns3.  disini saya menggunakan 5 router. dimana rinciannya :

R1, R2, R3, R3, dan XRV. untuk ios R1-R4 saya menggunakan ios 7200, dan XRV ios XR.

R3 sbg CE-Router

R4 sbg : INTERNET

langsung saja, BGP Weight attribute konsepnya semakin tinggi nilai WEIGHT semakin dipilih routesnya . CMIIW

langsung saja configurasi tiap router :

R2#
interface FastEthernet0/0
ip address 172.16.200.1 255.255.255.252

interface FastEthernet1/0
ip address 172.16.21.1 255.255.255.252

interface FastEthernet1/1
ip address 192.168.23.1 255.255.255.0

Basic MPLS Configuration (CISCO-XR)

Posted: March 18, 2015 in Cisco, MPLS

Apa itu MPLS ? jawabannya bisa cari di mbah Google ya gan. ane juga newbie jugaūüėÄ. kali ini mau share simulasi BASIC MPLS dg GNS3 (IOS-XR). yah thread seperti ini sdh banyak di shared di blogger engineer. tapi gpp ya, ane shared juga.

Berikut datek GNS3 :

1. Menggunakan 4 router : 2 router PE (IOS-XR), dan 2 router CE (Cisco-3725)

2. Antar PE menggunakan IGP + MP-BGP

3. CE-R1 menggunakan static-route/default-route, dg vrf cust-a

4. CE-R2 menggunakan ospf area 10, dg vrf cust-b

Berikut topologinya :

mpls_topologi

 

 

 

Berikut konfigurasi WGB di AP ad-hoc. Secara konsep sama dengan perangkat router wireless lainnya yaitu menggunakan bridges. Jika di dalam mikrotik  yang dibridge adalah Vlan dan interface WDS. Frekuensi yang digunakan bisa menggunakan 802.11a, 802.11b/g, atau 802.11n. Jika menggunakan 802.11a interface yang aktif  adalah Dot11Radio 1, tapi sebaliknya jikan 802.11b/g menggunakan interface Dot11Radio O.  Kali ini simulasi yang digunakan yaitu 802.11b/g

Vlan yang akan dilewati kedua AP yaitu vlan 10, vlan 20, dan vlan 30

Konfigurasi AP-ROOT

1. Konfigurasi Global dot11

dot11 ssid WGB2
vlan 1
authentication open

bridge irb

2. Konfigurasi interface dot11 O
!
interface Dot11Radio0
no ip address
no ip route-cache
!
ssid WGB2
!
antenna gain 0
stbc
beamform ofdm
speed basic-54.0 m8. m9. m10. m11. m12. m13. m14. m15.
power local 2
power client 13
station-role root bridge wireless-clients
infrastructure-client
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1

interface Dot11Radio0.10
encapsulation dot1Q 10
no ip route-cache
bridge-group 10
bridge-group 10 subscriber-loop-control
bridge-group 10 spanning-disabled
!
interface Dot11Radio0.20
encapsulation dot1Q 20
no ip route-cache
bridge-group 20
bridge-group 20 subscriber-loop-control
!
interface Dot11Radio0.30
encapsulation dot1Q 30
no ip route-cache
bridge-group 30
bridge-group 30 subscriber-loop-control
bridge-group 30 spanning-disabled

interface GigabitEthernet0

no ip address
no ip route-cache
duplex auto
speed auto
!
interface GigabitEthernet0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
!
interface GigabitEthernet0.10
encapsulation dot1Q 10
no ip route-cache
bridge-group 10
!
interface GigabitEthernet0.20
encapsulation dot1Q 20
no ip route-cache
bridge-group 20
!
interface GigabitEthernet0.30
encapsulation dot1Q 30
no ip route-cache
bridge-group 30

Konfigurasi AP-Client

1. Konfigurasi Global dot11

dot11 ssid WGB2
vlan 1
authentication open

bridge irb

2. Konfigurasi interface dot11 O
interface Dot11Radio0
no ip address
no ip route-cache
!
ssid WGB2
!
antenna gain 0
stbc
beamform ofdm
power local 2
power client 13
station-role workgroup-bridge multicast mode infrastructure
infrastructure-client
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
!
interface Dot11Radio0.10
encapsulation dot1Q 10
no ip route-cache
bridge-group 10
!
interface Dot11Radio0.20
encapsulation dot1Q 20
no ip route-cache
bridge-group 20
!
interface Dot11Radio0.30
encapsulation dot1Q 30
no ip route-cache
bridge-group 30

interface GigabitEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
!
interface GigabitEthernet0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
!
interface GigabitEthernet0.10
encapsulation dot1Q 10
no ip route-cache
bridge-group 10
!
interface GigabitEthernet0.20
encapsulation dot1Q 20
no ip route-cache
bridge-group 20
!
interface GigabitEthernet0.30
encapsulation dot1Q 30
no ip route-cache
bridge-group 30

Konfigurasi ad-hoc wgb Cisco AP 3502

Posted: November 12, 2012 in Cisco

Biar ga lupa, mau dokumentasikan konfiguasi AP-3502 mode Workgroup Bride (WGB) ata stand-alone tanpa Wireless Controller (WLC) di 802.11G

Konfigurasi AP-Root :

interface Dot11Radio0
no ip address
no ip route-cache
!
ssid wgb_risti1
!
antenna gain 0
speed basic-1.0 basic-2.0 basic-5.5 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
channel 2472
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
end

Konfigurasi wgb-client :

ap-root-10.100.10.1(config-if)#do sh run int dot 0
Building configuration…

Current configuration : 183 bytes
!
interface Dot11Radio0
no ip address
no ip route-cache
!
ssid wgb_risti1
!
antenna gain 0
station-role workgroup-bridge
bridge-group 1
bridge-group 1 spanning-disabled
end

Verifiy ping root to client :

ap-root-10.100.10.1(config-if)#do ping 10.100.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.100.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/3 ms
Cek RSL (Receive Signal Level) / RSSI :

ap-wgb-10.100.10.2#sh dot11 st cl int dot 0

Dot11Radio0: — Client Statistics
—Clients¬†¬†¬†¬† AID VLAN¬†¬†¬†¬†¬† Status¬†¬†¬† Age¬† Tx¬†¬† Mode Enc Key¬†¬†¬†¬†¬†¬† Rate
d48c.b5ad.b6fe   1    0 00 100 000 0FF 30   0-0  00B0 000 0-0  0EFC0000 06C 060
RxPkts KBytes  Dup Dec Mic   TxPkts  KBytes  Retry RSSI SNR
d48c.b5ad.b6fe   213944  36622  208   0   0   274961   34961  15499   27  73
WGB clients
0003.0108.1db6 Parent d48c.b5ad.b6fe 4
IP Address      Pauses   RSC
0003.0108.1db6 0.0.0.0         00000
d48c.b5ad.b6fe 10.100.10.1     00000
Video Report:  Cnt  Rate  Retries/Tot
8021x auth in prog 0 allowed 0

ap-wgb-10.100.10.2#sh dot11 ass all
Address           : 0003.0108.1db6     Name             : NONE
IP Address        : 10.10.29.182       Interface        : Dot11Radio 0
Device            : WGB-client         Software Version : NONE
CCX Version       : NONE               Client MFP       : Off

State             : Assoc              Parent           : d48c.b5ad.b6fe
SSID              : wgb_risti1
VLAN              : 0
Hops to Infra     : 0
Clients Associated: 0                  Repeaters associated: 0

Address           : d48c.b5ad.b6fe     Name             : ap-root-10.100.
IP Address        : 10.100.10.1        Interface        : Dot11Radio 0
Device            : WGB                Software Version : 12.4
CCX Version       : 5                  Client MFP       : Off

State             : Assoc              Parent           : self
SSID              : wgb_risti1
VLAN              : 0
Hops to Infra     : 1                  Association Id   : 1
Clients Associated: 1                  Repeaters associated: 0
Tunnel Address    : 0.0.0.0
Key Mgmt type     : NONE               Encryption       : Off
Current Rate      : 54.0               Capability       : WMM ShortHdr ShortSlot
Supported Rates   : 1.0 2.0 5.5 12.0 18.0 24.0 36.0 48.0 54.0
Voice Rates       : disabled           Bandwidth        : 20 MHz
Signal Strength   : -29  dBm           Connected for    : 1340 seconds
Signal to Noise   : 70  dB            Activity Timeout : 30 seconds
Power-save        : Off                Last Activity    : 0 seconds ago
Apsd DE AC(s)     : NONE

Packets Input     : 213994             Packets Output   : 275001
Bytes Input       : 37505260           Bytes Output     : 35804250
Duplicates Rcvd   : 208                Data Retries     : 15499
Decrypt Failed    : 0                  RTS Retries      : 0
MIC Failed        : 0                  MIC Missing      : 0
Packets Redirected: 0                  Redirect Filtered: 0

Cek Neighbor :

ap-wgb-10.100.10.2#sh cdp nei detail
————————-
Device ID: ap-root-10.100.10.1
Entry address(es):
IP address: 10.100.10.1
Platform: cisco AIR-SAP3502I-C-K9   ,  Capabilities: Trans-Bridge IGMP
Interface: Dot11Radio0,  Port ID (outgoing port): Virtual-Dot11Radio0
Holdtime : 148 sec

Version :
Cisco IOS Software, C3500 Software (AP3G1-K9W7-M), Version 12.4(25d)JA, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by Cisco Systems, Inc.
Compiled Thu 09-Dec-10 14:38 by prod_rel_team

advertisement version: 2

R1 (Sebagai PE Router) :

ip vrf to-r2
rd 2:2
!
ip vrf to-r3
rd 3:3
!
ip vrf to-r4
rd 4:4
!

interface FastEthernet0/0
ip vrf forwarding to-r2
ip address 172.16.234.1 255.255.255.252
!
interface FastEthernet0/1
ip vrf forwarding to-r3
ip address 172.16.234.1 255.255.255.252

interface FastEthernet1/0
ip vrf forwarding to-r4
ip address 172.16.234.1 255.255.255.252

Config ip p2p (R2-R3-R4) sama :

R4(config-router)#do sh run int f0/0
Building configuration…

Current configuration : 99 bytes
!
interface FastEthernet0/0
ip address 172.16.234.2 255.255.255.252

Verify ip route tiap router CE (R2,R3,R4)

R1#sh ip route vrf to-r2

Routing Table: to-r2
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/30 is subnetted, 1 subnets
C 172.16.234.0 is directly connected, FastEthernet0/0
R1#sh ip route vrf to-r3

Routing Table: to-r3
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/30 is subnetted, 1 subnets
C 172.16.234.0 is directly connected, FastEthernet0/1
R1#sh ip route vrf to-r4

Routing Table: to-r4
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/30 is subnetted, 1 subnets
C 172.16.234.0 is directly connected, FastEthernet1/0

Verify ping from R1 to Router CE (R2,R3,R4)

R1#ping vrf to-r2 172.16.234.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.234.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/40/72 ms
R1#ping vrf to-r3 172.16.234.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.234.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/54/116 ms
R1#ping vrf to-r4 172.16.234.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.234.2, timeout is 2 seconds:
!!.!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 68/85/132 ms

Salam,

Wiwid

 

Image  —  Posted: November 5, 2012 in Cisco, Networking

Berikut simulasi redistribute OSPF into BGP. Ada beberapa trik agar labs simulasi ini bisa berjalan.
Karena nilai AD atau preference OSPF lebih kecil dari preference BGP. Maka, kita harus manipulasi nilai AD/Preference OSPF lebih besar dibanding preference BGP. CMIIW. Berikut network simulasinya..

Design By Wiwid

Konfigurasi R1 :

[edit logical-routers r1]

Konfigurasi R1

Konfigurasi R2 :

Konfigurasi R2_Interfaces

Konfigurasi R2_Protocols

Konfigurasi R2_Policy

Verifikasi cek show route ip loopback R3 dari R1.

show route ip loopback r3 from r1

Dalam simulasi lab ini, redistribute static to ospf. Dimana R1 dan R5 mempunyai default route.
Dan R2,R3,R4 menggunakan protocol OSPF dengan area 0. Untuk verifikasinya, dengan cara ping dari router R1 ke R5 atau sebaliknya.

Konfigurasi R1

Konfigurasi R2

Konfigurasi R3
</a
Konfigurasi R4

Konfigurasi R5

Ping R1 ke R5

wiwid@jkt-home-jnp# …ping 172.16.40.2 logical-router r1 rapid count 50
PING 172.16.40.2 (172.16.40.2): 56 data bytes
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
— 172.16.40.2 ping statistics —
50 packets transmitted, 50 packets received, 0% packet loss
round-trip min/avg/max/stddev = 1.203/2.333/24.358/3.677 ms

Ping R5 ke R1

wiwid@jkt-home-jnp# run ping 172.16.10.2 logical-router r5 rapid count 50
PING 172.16.10.2 (172.16.10.2): 56 data bytes
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
— 172.16.10.2 ping statistics —
50 packets transmitted, 50 packets received, 0% packet loss
round-trip min/avg/max/stddev = 1.208/4.105/78.250/11.071 ms